Download LA.Store

Download LA.Store for your Operating System

LA.Store Downloads




Requirements
  • FreeBSD 9.3 or higher, GTK2, and minimum of 20 MB disk space
  • Linux Kernel 2.6 or higher, GTK2, and minimum of 20 MB disk space
  • Mac OSX Leopard or higher and minimum of 20 MB disk space
  • Windows XP or higher and minimum of 20 MB disk space
Important Note
By downloading any of the above software you are automatically agreeing to our "Terms, Policies, and User Agreements"

Can't Download?

Get in touch with us and let's talk about it.